Jamie dipchand
Hi guys, 

I recently started rebuilding a speed world challenge touring car it has a pectel t6. I downloaded descpro but it won’t connect to the  ecu the car does start and run.  50D4D382-3171-404B-ABB7-803F5BD4A3B2.jpeg 
Quote 0 0
littleozfella
Hi,
   How are you trying to connect, with RS232?  Firewall is first stop, switch off all firewall and Anti-virus settings.  After that I would probably guess you are using USB adaptor, use a reliable tested one, many of these are not so reliable. Can't recommend as I use Panasonic CF52 laptops with RS232 port..  Also I see you have Win 7 or 8. If you have Win 10 laptop I recommend, This platform is much more stable and the colours of the screen will be correct.. You want to vomit after looking at the screen in Win 7 for an hour or so..
Quote 0 0
Jamie dipchand
I will try your recommendations tomorrow thank you 
Quote 0 0
Jamie dipchand
67B4E622-B9B1-49A7-8385-0DE9B6AFFCFC.jpeg I have the program running but it’s asking for a profile now not sure what to do?
Quote 0 0
littleozfella
PM'd
Quote 0 0
Jamie dipchand
All taken care of thanks again littleozfella
Quote 0 0
Neil
Similar problem as on this thread... but just starting out.  We also have an older Speed World Challenge Touring car (Mercedes C230) with a Pectel T6 ECU.  I understand I need the Pectel "offload tool" and the "toolbox" in order to download to my laptop with subsequent analysis in "Descpro".  Seems Descpro is no longer something that can be downloaded....  Is there another option?  Can I use the PI downloads supported by Cosworth?  Any thoughts on how to access these older Pectel ECUs?  Having difficulty finding anything that might work....  Also, can someone explain the relationship of Pactel, and Cosworth?  Did Cosworth buy Pactel or?  Is PI research part of this?
Quote 0 0
littleozfella
Hi Neil,
               I have sent you a PM.
Cheers
Quote 0 0