ES Motorsport
Hi Cosworth,

We have a Lotus GT4 car in the race workshop running an SQ6 ECU but I am unable to connect a new laptop to the ECU.

I believe this could be because the laptop and software setup is missing a Metafile for the SQ6. Where can I get a Metafile from?

The ECU label shows:

PECTEL SQ6
01E-500700
S/N:1493 Iss:1/12

Is there anything else that will stop the laptop communicating with the ECU?

I look forward to any help you can give me, Mark.
Quote 0 0
Jake_Hardy
Hi Mark,

There could be a number of reasons why you cannot detect a device in CalTool. Have you tried to follow the steps from the CalTool 'Help' section (Help > Help Topics). 

How are you connecting to the device, I'm presuming you are connecting via Ethernet? It may well be that your firewall is blocking connectivity. If you 'Allow Program Through Firewall', select CalTool and see if this helps.

Alternatively, do you see any ECU information in the bottom right hand corner of CalTool besides the green license symbol? If you have a missing metafile you will see the device appear in the bottom right hand corner and it will state 'unknown metafile'.

Any further information you can provide would be great.

Thanks,

Cosworth Support
Cosworth Electronics 

Quote 0 0
ES Motorsport
Hi Jake,

Thanks for your reply.

I am trying to connect to the ECU via Ethernet. I had already allowed CalTool through the Firewall to see if this helped.

I am not with the car at the moment so I cannot confirm if I see the ECU information in the bottom right hand corner or not, I will see if the team can give it a try in my absence.

When we get the connection working will we need a Metafile anyway as the laptop is a new laptop with everything re-installed?

Thanks,

Mark.
Quote 0 0
Jake_Hardy
Hi Mark,

Have you been able to get any information from your team?

If not, there are still a couple of things for you to try. First step I would try to ping the device using command prompt. In the command window type the following - Ping -t 172.16.64.2. If you get a response then move onto the next step, if you do not get a response then this is an issue with your ethernet connection to the device. 

Ensure you have the correct personality file installed on your PC (http://support.cosworth.com/post/latest-software-release-announcements-and-downloads-for-pi-caltool-9610496?pid=1302790514). This acts as a license file. 

If you are getting a connection to the device, but you are missing a metafile then Caltool will report this. If you can connect to a device, it should appear in the bottom right hand corner of the CalTool window, along with the current firmware version of the device. If you can see this, then please let me know the ECU firmware version and device type (SQ6 TURBO,SQ6M NA etc) and I will supply you with the relevant metafile. 

Please try the suggestions above and let me know if you are still having issues.  

Kind regards,

Cosworth Support
Cosworth Electronics 

Quote 0 0