IT
When you try to run the field update file, you receive an error message stating that "A valid dongle must be present in the Parallel or USB Port" even though the dongle is valid.  The dongles work in Toolbox ver 6.1 on Win 10 machines prior to 1809 release.

Thanks!
Quote 0 0
littleozfella
I use latest windows 10 and have no issues, I updated our dongles last week    There is a possibility the dongle ID has been typed in wrong. Spaces or capitols incorrect, the Dongle name must be 100% match.  I sent you private message with tool to check dongle ID.
Cheers
Quote 0 0
IT
I have replied to your private messages. Thank you.
Quote 0 0
CosworthSupport
Hi IT,

Have you installed that latest dongle tools from the following post?

https://support.cosworth.com/post/pi-toolbox-pro-dongle-license-field-update-windows-10-v1803-issue-fixed-9807784?pid=1307158698 
Cosworth Support
Cosworth Electronics
Quote 0 0
littleozfella
Yes he has run this update..  The issue is later versions seem to made another issue.  I think IT is US time zone so I guess he will confirm a little later.

Cheers
Quote 0 0
IT
Yes, I have install Pi Field update 4.0.57.0 and it has corrected the issue on 1803.  However, I have machines running 1809 and 1903 and Pi does not recognized the dongle in either.  It does recognize the user in the lower right corner of Pi, but the Task window indicates No Dongle. I've attached a few screenshots...screenshot1.png screenshot2.png screenshot3.png screenshot4.png 
Quote 0 0
CosworthSupport
Thanks IT,

I don't think this is the same issue. I think the update is being applied and your issue is nothing to do with the Windows update. My PC is at the 1809 update and uses the 4.0.57.0 tools without any problem and changes the dongle settings.

I think the issue here is that you have a dongle with abnormal limits and the dongle update you have isn't set to alter the limits.

For reference the limits are stored in 2 places, on the dongle and in the PC registry, these have to match. The message that Toolbox shows in the help menu is telling us that currently these don't match.

I expect you just need a field update producing that sets the limits as well in addition to the normal license time extension.

I'll drop you and email and if you can send me your Toolbox workbook you are trying to use and the field update you are running and I can issue you a new one and get you up and running.  
Cosworth Support
Cosworth Electronics
Quote 0 0
littleozfella
I'm out of office for 2 weeks without the laptop with problem but I would say all worked fine. We had some windows issues so we did a hard drive change and clean windows install. Same version of Toolbox, same workbook but I must admit, didn't apply the field update to the new instalation. 
Quote 0 0
IT
I just replied to email with necessary information.  Thank you!
Quote 0 0